Xp Name Cancer

Once upon a time, a lot of people questioned the name "ExtremeProgramming". The XP guys stuck to their guns - name it and they will come, they said. These days there's no question that the name works, apt or not, and people feel happy with it.

But now Beck & co seem to be having conniptions over the practice names. We don't have LoadFactor, but ProjectVelocity. CommitmentSchedule is called something weird too. FunctionalTests are being renamed AcceptanceTests. Even the ListeningTestingCodingRefactoring is all morphed into ambiguity. The whole thing is beginning to smack of the MS OLE/COM/ActiveX/COM+ renaming nightmare.

XP guys, I don't care what you want to call these things, I'm going to call them what you called them first. You had a reason for picking those first names, and that reason was that they communicated something to you. Now you think you've got something more apt, but you're not weighing the value of its aptness against the cost of the confusion the renaming will cause. Plus, most of your renamings go from a concrete but perhaps overextended term to a vague but more abstract term. This isn't a good thing. To quote Popeye, any way you slice it, it's baloney.

So beware, neologues, be you high extremos or not, I'm going to keep talking like a hick from the sticks until you explain to me why the heck I oughtn't. Do not adjust your terminology. Adjust its meanings. -- PeterMerel.

I guess it's hard to refactor XP itself.

Personally, FunctionalTest has more obvious meaning to me that AcceptanceTest.. I understand that both names are an attempt at tying the name to a meaning of 'fulfilling UserStories' but neither seems better to me.

-- ShaeErisson

CommitmentSchedule is renamed ReleasePlan. The reason is that "commitment" was misleading, as it is a plan but not a commitment to a specific set of features in a specific time.

FunctionalTest is renamed AcceptanceTest. The reason is that AcceptanceTest is closer to standard usage in the testing community. Use of non-standard terminology can't help.

ProjectVelocity isn't a rename of LoadFactor. There is no division in ProjectVelocity; there is in LoadFactor.

Follow or follow not. There is no whine. -- RonJeffries

Um ... if you strike me down I will become more confused than you can possibly imagine. It's the tradeoffs mentioned above you're not caring for. The irksomeness of CS isn't significant once it's explained. The testing community would catch up with FT. And as for LoadFactor, life creates it, makes it grow. Its delays surround us and bind us. Real beings are we, not these ideal estimates. You must feel the LoadFactor around you. Here, between you... me... the story ... the task ... everywhere! Yes, even between this page and your project!

Use the other end, Luke!

Talk straight old man. Crazy old coot never can just spit it out. Always gotta be making a big ol' racket. Think I'm gonna just light out and refactor me them two fancy droids as hunter-killers and ketch a mess o' wamp-rat for supper. Wamp-rat chitlins with wamp-rat gravy and wamp-rat fritters, an a big ol' sweet-wamp-rat pie for afters. Mm-mmm, we livin' high on the hog tonight! -- Luke Bodine

Follow or follow not. There is no whine. -- RonJeffries

Oh, here we go again. Listen up, Merel and all you other whiners out there! Ron is right, now and forever. You can do what you like, but if you don't do it like Ron says YouArentExtreme, and that's all there is to it. Jeez, you wanted the name of the whole thing changed, well they never did that, but they are changing some of the other names. Won't you ever be happy?

The names will only change if we learn something. -- KentBeck

EditText of this page (last edited September 16, 2005) or FindPage with title or text search